We recently became aware of a security vulnerability within our Act! Pro, Act! Premium, and Act! Growth Suite software that may make it easier for a threat actor to gain unauthorised access to your system. To address this vulnerability, updates are being made available for supported versions of Act!.  View the Act! Support Obsolescence PolicyBecause your version of Act! is no longer supported, you will need to upgrade to Act! v24 Update 4 to address this issue.

To discuss your upgrade options, call 020 3835 2800 or contact your Act! Certified Consultant. Customers who host or sync their software via a 3rd party hosting provider should contact that provider immediately to discuss the appropriate remedy.

Have you seen Act! lately?

Check out the video below to see what’s new in Act.

Have a question?

We’re here to help! Explore Act! resources below.

Make an Appointment
Email Us
Submit a ticket

Ready to subscribe?

Call us at 020 4538 9097 or contact your Act! Certified Consultant.